您好,欢迎来到达州工业云! 平台首页 企业驾驶舱 帮助中心 企业登录 企业注册

HI,欢迎使用达州工业云平台!

账号必须大于2位

创新资源平台
服务平台首页>专利库>专利详情

实现一体化网络中普适服务的方法

  • 申请号:CN200610169726.3 申请公布号: CN101212464A
  • 申请日: 2006-12-28 申请公布日: 2008-07-02
  • 申请(专利权)人: 专利代理机构: 北京市商泰律师事务所
  • 分类号:H04L29/06

专利介绍

实现一体化网络中普适服务方法涉及一种提供所有服务的一体化网络体系结构。为克服现存的各种网络互通性较差的问题,本发明提供了一种方法确保向用户提供一致的、普遍的业务。本发明的技术方案是:在一体化网络的网通层的基础上建立服务层;在服务层的基础上提供各种服务。本发明提出的技术方案克服了传统互连网、电信网中对不同服务不能有效良好支持的缺点,实现了数据、语音、视频业务的统一服务标识。采用连接标识ID统一作为主机的唯一身份标识解决了移动性和安全性问题,为一体化网络下的普适服务技术发展奠定了必要的技术基础。
1.实现一体化网络中普适服务的方法,包括:一体化网络,其特征在于所 述的步骤: 建立网通层; 在所述网通层的基础上建立服务层; 将各种业务、网络资源、用户绑定服务标识符; 从虚拟服务子层到虚拟连接子层的映射; 从虚拟连接子层到网通层的映射。
2.根据权利要求1所述的实现一体化网络中普适服务的方法,其特征在于, 在所述的服务层中建立虚拟连接子层和虚拟服务子层,所述的虚拟连接子层和 虚拟服务子层中含有服务标识解析映射和连接标识解析映射。
3.根据权利要求2所述的实现一体化网络中普适服务的方法,其特征在于, 在所述的连接标识解析映射为: ( z 1 X ( n ) ID , z 1 ( n ) CNo ) ( z 2 X ( n ) CID , z 2 ( n ) CNo ) · · · ( z M X ( n ) CID , z M ( n ) CNo ) = Δ Ψ z 11 X ( n ) RID , z 12 X ( n ) RID , · · · · · · , z 1 K X ( n ) RID z 21 X ( n ) RID , z 22 X ( n ) RID , · · · · · · , z 2 K X ( n ) RID · · · z M 1 X ( n ) RID , z M 2 X ( n ) RID , · · · · · · , z MK X ( n ) RID M × K ]]>
4.根据权利要求2所述的实现一体化网络中普适服务的方法,其特征在于, 在所述的服务标识解析映射为: z 1 ( n ) SID z 2 ( n ) SID · · · z N ( n ) SID = Δ Φ ( z 11 ( n ) CID , z 11 ( n ) CNo ) , ( z 12 ( n ) CID , z 12 ( n ) CNo ) · · · , ( z 1 M ( n ) CID , z 1 M ( n ) CNo ) ( z 21 ( n ) CID , z 21 ( n ) CNo ) , ( z 22 ( n ) CID , z 22 ( n ) CNo ) · · · , ( z 2 M ( n ) CID , z 2 M ( n ) CNo ) · · · ( z N 1 ( n ) CID , z N 1 ( n ) CNo ) , ( z N 2 ( n ) CID , z N 2 ( n ) CNo ) · · · , ( z NM ( n ) CID , z NM ( n ) CNo ) N × M . ]]>
5.根据权利要求2所述的实现一体化网络中普适服务的方法,其特征在于, 网通层通过连接标识解析映射与虚拟连接子层联接。
6.根据权利要求2所述的实现一体化网络中普适服务的方法,其特征在于, 所述的服务标识解析映射应用于基于服务触发的标识的方法,所述的方法包括 以下步骤: 通信终端向基于服务触发的标识系统注册自己所支持的服务标识ID; 用户根据自己的需要查询、搜索并获取所希望的服务标识ID; 用户根据获取的服务标识ID,从中获知该标识对应的服务在网络中的位 置。 技术领域 本发明涉及一种实现一体化网络中服务方法,是一种计算机网络技术, 特别涉及一种提供所有服务的网络体系结构。 背景技术 现有的信息网络按照业务范围的不同,主要可以分为电信网(包括固定电 话网和移动电话网)、电视网以及互联网。下面分别对这些网络进行简要描述。 现有的固定电话网主要是基于程控数字交换技术的网络,主要用于传输语 音。程控数字交换网由用户驻地网、接入网与核心网组成,程控数字交换网开 始是为传输语音信号而设计,采用电路交换的方式,不能很好的支持数据传输 和图像传输;另外,由于程控数字交换网是为固定用户终端设计的,因此它不 能很好的支持用户终端的移动性。而移动通信技术作为通信领域的一个分支近 年来发展非常迅速。目前大部分全球移动通信系统所采用的蜂窝电话技术是 2G,它的传输技术主要是时分多址(TDMA)。2G的数据传输速率低,只有 9.6Kbps。3G是第三代移动通信技术,传输技术主要是码分多址(CDMA)的 三种形式:WCDMA、CDMA2000和TD-SCDMA,数据传输速率为高速运 动状态下达到384Kbps,静止状态下达到2Mbps。移动通信技术较好的解决了 用户终端的移动性问题,但是由于移动通信采用无线信道传输,因此数据传输 速率都较低,并且由于较高的误码率,使得移动通信技术不适合于传输会议电 视、视频图像等对服务质量要求很高的实时业务。 电视网主要用来传输图像,向用户单向传送电视节目。目前的电视网是一 个专门提供广播电视业务的网络,无法提供语音和数据业务,也无法进行双向 通信。 近年来,随着Internet网的迅速发展,互联网已经成为三大网络(互联网、 电信网、电视网)中发展最快的网络。互联网遵从TC/IP的四层体系结构(包 括子网层、网络层、传输层、应用层),采用面向无连接的分组交换技术传输 数据并提供“尽力而为”的服务。但这种无连接的特性也正是互联网从单一的数 据传输网向多业务承载网演进的瓶颈。互联网提供的尽力而为服务特性根本不 能保证传输的可靠性,并且由传输层的传输控制协议(TCP)引入的重传时延 对于语音、视频等对实时性要求很高的业务来说也是不能忍受的。虽然说引入 了一些服务质量(QoS)机制来解决互联网传输实时业务的问题,但这些机制 在大规模网络上实施都存在着许多问题,不能从根本上解决互联网的问题。另 外,互联网设计之初是为固定终端服务的,它不能很好的支持终端的移动性。 从以上分析可以看出,现有的信息网络采用面向业务的网络服务体系结 构,分层进行建设和管理,新增重要业务和技术都是采用一个个独立的网络层 面实施,每种业务都有自己的网络平台,不仅建网成本很高,而且由于每一层 的管理和控制方法是在不同的历史条件和应用环境下发展起来的,各层的控制 方法存在很大的差异,整个网络的管理变得十分复杂,运营成本十分高昂。随 着IP成为主要业务量后,在语音时代有用的很多功能将变得毫无意义,多层 结构中的很多层面将会逐步消失,整个功能结构层次变得简单和扁平化。信息 网络的集成将从垂直方向向水平方向发展。 把语音、数据和图象综合起来传送,达到全业务信息的迅速交流和资源共 享的效果,是实现知识经济乃至信息社会所必经的技术途径。现有的互联网、 电视网和电信网早已分别建成,传统的行业分割使各种信息行业都在自行其 事。在多种网络并存的情况下,各种服务纷繁复杂,浪费了资源又不利于用户 的使用。因此,实现各种处理音频、视频和数据服务的统一非常迫切。 正是随着网络体系结构的演变和宽带多业务移动网络技术的发展的这一 大趋势,传统网络正在向下一代网络演进。下一代网络并不是一个新的网络, 而是基于现有的多种网络演进融合而来的。当前电信界和计算机界对下一代网 络有不同的看法。由于原有的网络基础不同、演进的路线不同,在标准制订过 程中的侧重点和解决方案也多有不同。在电信界看来下一代网络的研究内容集 中在传输层以及业务层:在传输层上主要集中在ASON(自动交换光网络); 在业务层上主要集中在软交换。在计算机界看来下一代网络就是NGI(下一代 互联网),NGI对传输层没有特殊要求,只需传输层提供尽可能的高带宽,工 作重点在业务承载层和业务层:在业务承载层上的规范集中在IPv6(因特网协 议版本6)协议;在业务层的规范主要体现在采用端到端控制的智能终端上。 为了加快下一代网络的标准化进程,ITU-T于2004年5月6日在日内瓦 成立了下一代网络焦点组(FGNGN),下设业务需求、体系架构与移动性、服 务质量、控制与信令、安全、网络演进、未来的分组网络等7个工作组,平均 每2个月举行一次会议,研究和制定与下一代网络相关的业界迫切需要的标准, 现已推出了较为具体的标准草案:“FRA-NGN的功能架构模型”标准草案初步 提出了下一代网络业务层和传输层的一些功能实体,该草案从逻辑功能实体的 角度来定义和分析下一代网络的模型;“FRMOB移动性功能需求”标准草案将 下一代网络的移动性分为网间移动、网内移动和接入网内移动三种情况,并提 出了对移动性管理的要求以及功能体系结构;“CMIP可管理的用户网络能力” 标准草案提出可管理IP网的业务是向用户提供网络资源控制和管理,可管理 IP网应具有用户分组及业务分集、信息接入控制和安全、移动控制和管理、带 宽分配和SLA协商、端到端QoS配置和优先权配置等多种功能。 计算机界标准化组织的代表IETF也为下一代网络制定了一系列的规范 [11]:IPv6分组在不同媒体上的承载方式,包括以太网、点对点协议(PPP)链 路、光纤分布式数据接口(FDDI)、令牌环、ARCnet等;IPv6基本协议,包 括RFC2460(互联网协议版本6)、RFC2675(IPv6巨型包)、RFC2507(IPv6头 压缩)等;IPv6地址相关协议,包括RFC3513(IPv6地址结构)、RFC2374(IPv6 可聚合全球单播地址)、RFC1887(IPv6单播地址分配)、RFC2375(组播地址 分配)等;IPv6组播相关协议,包括RFC2710(IPv6MLD)、RFC3306(基于 单播地址的IPv6组播地址)等;业务相关协议,包括用于建立语音或者视频 会话的SIP、用于控制媒体网关的媒体网关控制协议(MGCP)等。 虽然计算机界与电信界在下一代网络上的研究各有侧重,但是对于下一代 网络的总体目标则比较一致:下一代网络是基于分组技术的网络,能够提供包 括电信业务在内的多种业务;在业务相关功能与下层传送功能分离的基础上, 能够利用多种宽带、有QoS(服务质量)支持能力的传送技术;能够为用户提 供无限制地接入到多个运营商的可能;能够支持广泛的移动性,确保向用户提 供一致的、普遍的业务。下一代网络的一个重要目标就是网络融合。 早在2002年,日本的NTT公司就制定了名为RENA(Resonantxa0Network Architecture)的下一代网络与网络结构发展计划,计划投资50亿美元。它 的目标是建立一个所有人都可以自由通信的网络。但是,应该看到,RENA计划 只是一个工程性的发展计划,单纯的依靠发展宽带网络和宽带接入并没有给互 联网本身的发展带来任何的理论创新,也没有解决互联网面临的广泛移动性、 性、多业务融合、普适性等众多基本问题,只是互联网发展的一个权宜之计; 2004年,英国电信提出了预计投资8000万英镑的“21CN”下一代网络建设计 划。它的主要目标是建设下一代网络,替代现有的电话交换网及互联网,形成 多业务融合的网络。21CN计划部分解决了诸如多业务、移动性和网络安全等问 题。但同时也应该看到,该项目并没有对信息网络今后的发展提出根本性的理 论支持,只是当前网络技术的较大修补与改进;美国国家科学基金会目前正计 划从根本上重新设计互联网,以解决现有的各种问题,打造一个更适合未来计 算机环境的下一代互联网,并于2005年8月22日公布了一个名为“全球网络 环境调查”(GENI)的项目。美国国家科学基金会认为下一代互联网的研究重 点是网络安全、手机、无线和传感器网络共同组成的普适计算(pervasive computing)环境,因此GENI项目主要包括一个研究计划和搭建一个测试环境。 GENI的研究计划主要包括:建立新的核心功能,设计新命名机制、地址和一 致性的体系结构,设计新的网络管理范例;强化现有体系结构的安全性,设计 高可靠性、可说明性的安全机制;设计一个新的体系结构,该体系结构可以和 新的无线技术、光通信技术、普适计算技术互相合作;设计更高层次的服务提 取结构,如信息目标、基于位置的服务、身份网络等;建立新的服务和应用, 如更安全、健壮、可控的大范围分布式应用,设计分布式应用的原理和模式; 建立新的网络体系结构原理,研究网络的复杂性、可量测性。但需要指出的是, GENI项目对新一代信息网络的研究还只是停留在决策层面或者起步阶段,并未 形成清晰的理论研究方案,某些研究项目也只是从新一代信息网络的某一个或 某几个方面展开研究,缺乏对新一代信息网络体系结构及关键理论与技术的全 面性和系统性研究。 发明内容 基于上述发展现状,为了克服现有技术的不足,本发明提供了一种实现一 体化网络与普适服务的方法,用于实现服务一体化、网络一体化。一种实现一 体化网络普适服务体系的方法允许包括固定用户和移动终端、移动子网、自组 网用户等多种移动性接入,固定用户和移动用户享有同样的个性化业务服务, 实现分布式网络资源的共享和查找服务,进行语音、数据、图像等业务的传输 并提供精细粒度的服务质量,确保向用户提供一致的、普遍的业务。 本发明的技术方案是:实现一体化网络中普适服务的方法,包括:一体化 网络,其特征在于所述的步骤: 建立网通层; 在所述网通层的基础上建立服务层; 将各种业务、网络资源、用户绑定服务标识符; 从虚拟服务子层到虚拟连接子层的映射; 从虚拟连接子层到网通层的映射。 在所述的服务层中建立虚拟连接子层和虚拟服务子层,所述的虚拟连接子 层和虚拟服务子层中含有服务标识解析映射和连接标识解析映射。在所述的连 ( z 1 X ( n ) CID , z 1 ( n ) CNo ) ( z 2 X ( n ) CID , z 2 ( n ) CNo ) . . . ( z M X ( n ) CID , z M ( n ) CNo ) = Δ Ψ z 11 X ( n ) RID , z 12 X ( n ) RID , . . . . . . , z 1 K X ( n ) RID z 21 X ( n ) RID , z 22 X ( n ) RID , . . . . . . , z 2 K X ( n ) RID . . . z M 1 X ( n ) RID , z M 2 X ( n ) RID , . . . . . . , z MK X ( n ) RID M × K ]]>接标识解析映射为: 所述的服务标识解析映射为: z 1 ( n ) SID z 2 ( n ) SID . . . z N ( n ) SID = Δ Φ ( z 11 ( n ) CID , z 11 ( n ) CNo ) , ( z 12 ( n ) CID , z 12 ( n ) CNo ) , . . . , ( z 1 M ( n ) CID , z 1 M ( n ) CNo ) ( z 21 ( n ) CID , z 21 ( n ) CNo ) , ( z 22 ( n ) CID , z 22 ( n ) CNo ) , . . . , ( z 2 M ( n ) CID , z 2 M ( n ) CNo ) . . . ( z N 1 ( n ) CID , z N 1 ( n ) CNo ) , ( z N 2 ( n ) CID , z N 2 ( n ) CNo ) , . . . , ( z NM ( n ) CID , z NM ( n ) CNo ) N × M ]]>网通层通过连接标识解析映射与虚拟连接子层联接。所述的服务标识解析 映射应用于基于服务触发的标识的方法,所述的方法包括以下步骤: 通信终端向基于服务触发的标识系统注册自己所支持的服务标识ID; 用户根据自己的需要查询、搜索并获取所希望的服务标识ID; 用户根据获取的服务标识ID,从中获知该标识对应的服务在网络中的位 置。 本发明的有益效果:我们提出的技术方案,克服了传统互联网、电信网中 对不同服务不能有效良好支持的缺点,实现了数据、语音、视频业务的统一服 务标识。同时,定义了合理的映射规则建立起服务标识到服务连接的合理映射, 实现了各种不同种类业务的普适化服务。同时,采用连接标识ID统一作为主 机的唯一身份标识有效的解决了移动性和安全性问题,为一体化网络下的普适 服务技术发展奠定了必要的技术基础。 附图说明 下面结合附图和实施例对本发明作进一步解释。 图1为本发明的体系结构示意图; 图2为本发明的服务层结构示意图; 图3为本发明的基于服务触发的标识方法的示意图; 图4为传统网络中间人欺骗攻击示意图; 图5为本发明拒绝服务攻击示意图。 具体实施方式 实现本发明的一体化网络与普适服务新型体系结构模型如图1所示,它包 括“网通层”和“服务层”两个大的部分。本发明所述的一体化网络是一种将 现有网络融合的网络,是将现有的互联网、移动通讯网、固定电话网,以及所 有与之连接的,用于传输数据、图像、流媒体、视频、音频信号的网络。这是 本发明所使用的硬件系统。本发明的宗旨是将现有的各种网络硬件融合,建立 适用各种服务的网络架构,减少网络结构层次,提高网络效率,完善网络服务。 一体化网络与普适服务体系是一种不同于OSI七层网络体系和互联网四层网 络体系的新型网络体系结构。一体化网络与普适服务体系将用户、业务和网络 资源三者有机统一为一个整体,很好的实现了网络一体化并为用户提供普适服 务。本发明的最终目标是用一体化网络与普适服务体系结构来替代现有的网络 体系结构,从而建立一个一体化网络平台,为多业务的传输提供多粒度的服务 质量,确保向用户提供的普适服务。普适服务概念是批判地继承OSI七层模型 以及互联网四层模型等已有技术后渐进浮现的。 “网通层”包括虚拟接入子层和虚拟骨干子层,为数据、语音、视频等业 务提供的一体化网络通信平台。“网通层”采用“间接通信”模式:虚拟接 入子层采用接入标识转发数据,而在虚拟骨干子层采用内部的交换路由标识替 代接入标识转发,到达通信对端的广义交换路由器后,数据包的交换路由标识 被置换回原来的接入标识;虚拟接入子层负责通信终端的接入,虚拟骨干子层 解决位置管理和交换路由理论,用户的隐私性、网络的安全性、可控可管性和 移动性在“网通层”得以很好的实现。 “服务层”的体系结构如图2所示。“服务层”主要负责各种业务的会话、 控制和管理,这些业务包括由运营商或第三方增值服务商提供的各种网络业 务,主要是语音、数据、流媒体等,不同的业务用同一个“服务层”承载。在 服务层中,各种业务、网络资源和用户都采用唯一服务标识符识别,各个应用 都要绑定于服务标识符,并且进行从服务标识符到连接标识符的解析、从连接 标识符到交换路由标识符的解析,从而建立普适服务的服务标识和连接标识解 析映射理论。服务层创新的引入两个虚拟子层:虚拟服务子层和虚拟连接子层; 两个解析映射:服务标识解析映射和连接标识解析映射。 虚拟服务子层是实现普适服务的基础,用于解决统一的服务对象调度,提 供服务的可控可管,为支持多种服务提供了可能,关键是引入了服务标识ID 的概念。服务标识的作用是对各种网络支持的服务进行统一的分类标识和定 位,体现普适服务的思想。为了实现更加合理的标识和定位,在总结了现有资 源标识系统(如域名服务系统DNS等)的优点与不足后,提出“基于服务触 发的标识系统”,如图3所示。一体化网络支持的服务应向参加标识系统的网 络节点发布一个它能支持的服务标识,用户根据自己的需要查询、搜索并获取 所希望的服务标识,用户根据获取的服务标识和该标识对应的服务在网络中的 位置,得到所需服务。 该标识系统的标识定义规则如下: 服务标识=属性+分类值 其中属性是对服务的统一分类,分类值是在这次分类下的进一步分类。例 如:属性可以是“数据服务”,而分类值是“文本数据服务”。图3中方形节点 代表属性,圆形节点代表分类值。从图3中可以看出,这种命名格式非常的灵 活。既可以根据属性分类,又可以根据分类值分类。 标识系统需要完成的核心工作是根据服务标识解析找出其在网络的位置。 为完成这一工作,上述标识树结构中的每个标识节点还需要对应一个记录项: 记录该标识对应的网络分布位置,到达该位置的方法等。标识系统查找工作就 是在这个标识树中,快速有效的找到需要的标识节点,并提取该节点对应的位 置记录项。基于上述树型结构的标识系统的一个可行、有效的查找办法是利用 适当的递归算法,逐渐减小搜索域,最终找到目标节点。 虚拟连接子层:该层引入了连接标识ID,作为服务连接和终端身份的标 识,是普适服务模型的核心,可以很好的支持移动性、安全性,并提供一定的 服务质量保证。 1.连接标识ID的引入可以从根本上解决移动性问题。在传统的基于TCP/IP 协议栈的互联网体系结构中,IP地址既作为主机的身份标识也作为主机的位置 标识。这种方式不利于支持主机的移动性,IP地址的变化会导致原来建立的传 输连接中断,需要重新建立连接。引入连接标识ID和服务标识向连接标识的 映射将提供一种身份与位置分离的移动性解决方法,把传统IP地址的双重功 能进行分离,交换路由标识作为主机的位置标识;同时连接标识ID作为主机 的身份以及一次服务连接的标识。该技术使得通信主机在无线移动的情况下仅 仅进行交换路由标识的切换,而标识服务连接的连接标识ID在这一过程中保 持不变,连接就不会中断。 2.提供安全服务是模型的另一特色。当前网络在安全方面面临的两个重 要挑战是欺骗和冒充问题,连接标识ID的提出将很好的解决这些难题。在图 4和图5中,以中间人欺骗攻击和拒绝服务攻击两个常见问题为例说明模型对 的支持。在中间人攻击中,攻击者向通信节点谎称目标节点在欺骗目标节点的 位置,于是通信节点被欺骗与欺骗目标节点通信,欺骗目标节点就可以窃取通 信节点的机密信息;在拒绝服务攻击中,攻击者冒充目标节点同时与多个通信 节点通信,使得目标节点在短时间收到大量的信息而拥塞。仔细分析这两种不 同的网络攻击不难看出,它们的本质都是地址的欺骗和地址的不安全使用。通 过引入连接标识ID,将其作为主机身份的标识,交换路由标识作为通信地址, 这样主机的通信地址即使由于移动切换或多家乡等问题改变,也不会影响连接 标识ID对主机身份的合法标识,根本上解决了网络中的欺骗和冒充问题。 3.随着移动设备逐渐增多,保证连接稳定性成为服务质量的一个重要组 成。普适的服务模型可以从根本上保证服务连接的稳定性,在连接这一层次提 供了服务质量的一定保证。 服务标识解析映射将虚拟服务子层和虚拟连接子层的工作联系起来,完成 服务对象标识到多个连接标识的映射,实现通信设备间的普适服务连接,映射 定义如下: z 1 ( n ) SID z 2 ( n ) SID . . . z N ( n ) SID = Δ Φ ( z 11 ( n ) CID , z 11 ( n ) CNo ) , ( z 12 ( n ) CID , z 12 ( n ) CNo ) , . . . , ( z 1 M ( n ) CID , z 1 M ( n ) CNo ) ( z 21 ( n ) CID , z 21 ( n ) CNo ) , ( z 22 ( n ) CID , z 22 ( n ) CNo ) , . . . , ( z 2 M ( n ) CID , z 2 M ( n ) CNo ) . . . ( z N 1 ( n ) CID , z N 1 ( n ) CNo ) , ( z N 2 ( n ) CID , z N 2 ( n ) CNo ) , . . . , ( z NM ( n ) CID , z NM ( n ) CNo ) N × M ]]>上式中zN(n)SID表示一种服务,下标N表示服务种类,SID是服务标识; (zNM(n)CID,zNM(n)CNo)表示在zN(n)SID服务下映射出的某一连接,M种连接类型选 择,下标CID是连接标识,zNM(n)CNo表示某一连接的连接号,用于区分每种连 接中的某个连接号,CNo表示连接号数;Φ(·)是服务标识解析映射的函数。从 上式可知Φ(·)是一对多的映射函数,完成一个服务到多个连接的映射;其逆映 射Φ-1(·)完成将连接子层收到的多个连接向一个服务的映射。该解析映射函数 的映射规则通过一定的哈希算法建立。哈希算法将任意长度的二进制值映射为 固定长度的较小二进制值,这个小的二进制值称为哈希值。哈希值是一段数据 唯一且极其紧凑的数值表示形式。如果散列一段明文而且哪怕只是更改该段落 的一个字母,随后的哈希过程都将会产生不同的值。要找到散列为同一个值的 两个不同的输入,在计算上是不可能的,所以数据的哈希值可以检验数据的完 整性,提高安全性。由于服务的多样性,所以可以用不同长度的二进制值来表 示不同的服务对象标识,而连接标识表示一个固定的连接信息,所以可以用固 定长度的二进制值来表示。基于此,实现服务对象标识到连接标识的映射是符 合哈希算法的映射规则的,在理论上可以完全实现。同时,这种映射方式保证 了数据的安全性和完整性。 连接标识解析映射将虚拟连接子层和网通层的工作联系起来,完成一个连 接标识到多个交换路由标识的映射,实现服务连接在网络上的多个路径选择, 提高了网络传送的可靠性,映射定义如下: ( z 1 X ( n ) CID , z 1 ( n ) CNo ) ( z 2 X ( n ) CID , z 2 ( n ) CNo ) . . . ( z M X ( n ) CID , z M ( n ) CNo ) = Δ Ψ z 11 X ( n ) RID , z 12 X ( n ) RID , . . . . . . , z 1 K X ( n ) RID z 21 X ( n ) RID , z 22 X ( n ) RID , . . . . . . , z 2 K X ( n ) RID . . . z M 1 X ( n ) RID , z M 2 X ( n ) RID , . . . . . . , z MK X ( n ) RID M × K ]]>上式中(zMX(n)CID,zM(n)CNo)表示一次连接,上标X表示某次服务,M表示某 次连接;zMKX(n)RID表示服务X的交换路由标识,M表示连接类型下标,K表示 某次选路,RID是交换路由标识;式中Ψ(·)是一对多的映射函数,完成一个连 接到多个选路的映射;其逆映射Ψ-1(·)将来至多条路径的信息映射回某次连接。 该过程同样采用类似的一对多哈希算法来完成连接标识到交换路由标识的映 射。 以上的描述在实际应用中的运行步骤如下: 步骤一、建立网通层 步骤1.建立网通层中的虚拟骨干子层。虚拟骨干子层主要用于解决位置 管理和骨干网络中的数据包交换路由问题。 步骤2.建立网通层中的虚拟接入子层。虚拟接入子层主要用于接收通信 终端的数据,并将其转发至虚拟骨干子层。 步骤3.通信源端的虚拟接入子层采用接入标识转发通信源端的数据包至 虚拟骨干子层。 步骤4.虚拟骨干子层采用内部的交换路由标识替代接入标识进行数据包 的转发,将数据包转发至通信对端的虚拟接入子层。 步骤5.通信对端的虚拟接入子层将交换路由标识替代为接入标识,将数 据包转发至通信对端。 步骤二、在所述网通层的基础上建立服务层; 步骤6.建立服务层的虚拟服务子层。虚拟服务子层用于解决统一的服务 对象调度,提供服务的可控可管。 步骤7.一体化网络中的每一个通信终端引入统一标识方法利用服务标识 ID对各种服务进行标识,服务标识ID信息应包括所支持的服务类型和服务特 性。通信终端维护服务类型以及服务特性与服务标识ID之间的对应关系。 步骤8.建立服务层的虚拟连接子层。虚拟连接子层用于标识一次通信连 接,引入连接标识ID作为服务连接和终端身份的标识。此连接标识ID不同于 传统网络中的连接标识,它由服务标识ID和通信双方的接入标识ID的信息组 成。 步骤三、通信终端查找所需服务的服务标识。 步骤9.通信终端首先向基于服务触发的标识系统注册自己所支持的服务 标识ID,以及该服务标识ID与终端位置的对应关系。 步骤10.终端根据通信的需要向标识系统查询所希望得到的服务对应的 服务标识ID的情况,从而获得支持该服务标识ID的服务器或终端的网络位置, 以及当前状态等。 步骤四、通过两次解析映射实现服务层一次服务对应的网通层选路。 步骤11.通过服务标识解析映射建立服务标识ID与连接标识ID的多对一 映射关系,连接标识ID应能反映出服务标识ID中对服务类型和服务特性的描 述。 步骤12.一个连接再通过连接标识解析映射映射到一个或多个网通层选 路。 经过以上全新的设计,普适服务层可以克服传统互连网、电信网对一体化 普适服务支持的两个缺陷:缺乏统一的服务标识;缺乏服务标识到服务连接的 合理映射,实现普适化服务;同时,服务标识ID为不同网络下的各种服务进 行统一的命名和管理,实现服务的可控可管,而连接标识ID可作为主机的唯 一身份标识在通信过程中保持不变,以提供移动环境下连接的稳定性,以及在 不安全网络环境下防止欺骗和冒充。